You are here

To upgrade or not?

4 posts / 0 new
Last post
chjohans
Offline
Donator
Joined: 10 years
Last seen: 1 month
To upgrade or not?

I've been using WG+ for a few years to grab EPG data for a few channels. The past couple of years it has been stable with no changes to the guide data source, so I have not paid much attention to the development here. I'm currently using version 3.3, and I noticed that WG+ has progressed to version 5.x.

Should I upgrade or is it fine to stay on the current version, which is completely stable for me?

And if I do upgrade, which version is recommended? All the betas always available here is a bit confusing.

And, can I just do an "in-place upgrade", eg just install the new version on top of the old?

Anything I should be aware of if I do decide to upgrade?

Oh, and thanks for the effort in keeping this alive and up to date!

On a side note, you really should support https on your website, some browsers even refuse to connect to your site with no https support...

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

You can always give it a try, make a copy and rename your wg++ folder and install dotnet to try version 5

chjohans
Offline
Donator
Joined: 10 years
Last seen: 1 month

Yes, I can always try, but I was kinda looking for advice. :)

Should I upgrade or is it fine to stay on my current v3.3, eg is v3.3 still being supported?

And again, you really should enable https on your website.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

If you don't have problem you can stay with 3.3.Of course many site change and sooner or later you may need to upgrade, as the new wg++ 5.x can solve this changes.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl