You are here

[update] tvtv.de.ini

64 posts / 0 new
Last post
fluffi444
Offline
Joined: 5 years
Last seen: 1 year
[update] tvtv.de.ini

Hey Guys,

since yesterday or few days ago the "tvtv.de.ini" (Germany) gives me "no shows in indexpage".
Looks like tvtv.de did some changes to their site.

Is it possible to check that and to get an update?

Many thanks for your outstanding work here!

I use latest WGP 2.1.5 and latest version of tvtv.de siteini @Revision 9 - [19/02/2015].

DoXer
Offline
Donator
Joined: 11 years
Last seen: 3 years

+1

Thanx in advance.

cbl
Offline
Joined: 7 years
Last seen: 5 years

Same problem here with 2.1.0.
I have no problems using other sites (e.g. "ZDF.DE"), but I preferred tvtv.de in the past.

Thanks for any help (and of course: many thanks for your great work for wg++!).

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

Same for me - would be happy if somebody can help

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

Made donation...

cbl
Offline
Joined: 7 years
Last seen: 5 years

Made donation using my nickname.

cbl
Offline
Joined: 7 years
Last seen: 5 years

Made donation using my nickname.

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

Hey ho Guys!

I just want to let you know that I found an quick and dirty workaround to get tvtv working again.
As I do not want to betray or disrespect the work of @Blackbear199 I want to ask him if its OK to post this here.
And for sure I do not want to stop someone of donating!

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

Ok - its time to give something back to the community.
Just replace the attached tvtv.de.ini with yours in folder:
C:\Users\*USER*\AppData\Local\WebGrab+Plus\siteini.user\Germany

Some additional words:
I replaced tvtv.de with tvtv.co.uk. This co.uk url is still old fashioned and works with old siteini. For sure I cannot say how long this will work or if tvtv will change this url in the near future as well. But for now its working lightning-fast.
And just to mention it: The 100% correct way would be to change to tvtv.co.uk in xml as well including changed files names. But I decided to make it quick and dirty so that you can leave the rest (incl your WebGrab++.config.xml) untouched. That means set everything as it was before for tvtv.de and just use the new tvtv.de.ini (don't forget to rename the downloaded file to that...)

Furthermore I changed the way to display series episodes to: S02E06/10 (Season 2, Episode 6 out of 10).

Don't forget that this is only an bushfix. If you want an solution for current tvtv.de site I guess Blackbear199 has an more professional solution for you.

Attachments: 
turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Hey everybody,
I'm new to Webgrabplus and also new to this Forum!
So, please excuse me if I do something wrong here.

What I'm trying to do is get wg++ running with tvtv.de, but I don't have any success.

What I found out (here in this trade) is, that Blackbear199 offers a solution.
So here my questions:
How do I get this solution?
What do I have to do, to get this Solution?
Is that solution still working?

Hope anyone is able to give me a helping hand.

Best regards,
turbo

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

First step, read the documentation, if you don't like reading see here http://webgrabplus.com/documentation/quick-start. Once you do that, if you still have problem, post your files so we can check what's wrong.

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Hello mat8861,
that's what I did to bring my installation up to run (reading the Doku).

The system is running ...
But only with data from "tvmovie.de". I'd like to use "tvtv.de" and that is not working, like described in this Trade.

Blackbear119 offered a solution and I'd like to use this if it is still gettable and working.

My be my Question wasn'd quite clear. ;)
Hope it's quite clear now. :-))

Anyway, thanks for answering!

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

Ok he posted working site ini here http://webgrabplus.com/forums/new-updates
You need to be donator to access.

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

So I just need to donate?
Is there a special Form how to do that?

Or just do and be happy?

Thanks for help!!

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

yes just donate as you want here http://webgrabplus.com/content/support-us
and be happy !!

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

[x] Done!
By using my Nickname, hope it work's :-)

Thanks for supporting me!!

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

Hi guys,

seems premiere tag does not be extracted as expected. Any hints?

Using @Revision 12 with 2.1.5
Greet

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

Please give a channel reference

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

https://www.tvtoday.de/programm/standard/sender/sat1.html (29.10.2ß18)

[ Debug ] No Block with these separators
[ Debug ] Debugging information SiteIni
[ Debug ] Element: PREMIERE
[ Debug ] scrub strings:
[ Debug ] type & arguments : debug
[ Debug ] blockstart (bs): multi(include="Neu")
[ Debug ] elementstart (es):
[ Debug ] elementend (ee): title="
[ Debug ] blockend (be): "

I tried to fix myself, but seems I'm to stupid to understand siteini debugging. ;-)

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

I see the problem. Will check as it seems there is a bug.

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Anybody know's how long it'l take until I'm able to get that *.ini from Blackbear199 ?

Thank's!

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

Once you have the badge you can access the donators area. If not by today send an email here http://webgrabplus.com/content/contact

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

@MinSWversion: V2.1.5
..
premiere.scrub {multi(include="Neu")||title="|"|}
premiere.modify {set(not "")|true}
..
No chance to revert back to 2.1

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

@Blackbear, your suggestion helped. Thank you very much.

fluffi444
Offline
Joined: 5 years
Last seen: 1 year
fluffi444 wrote:

Ok - its time to give something back to the community.
Just replace the attached tvtv.de.ini with yours in folder:
C:\Users\*USER*\AppData\Local\WebGrab+Plus\siteini.user\Germany
Some additional words:
I replaced tvtv.de with tvtv.co.uk. This co.uk url is still old fashioned and works with old siteini. For sure I cannot say how long this will work or if tvtv will change this url in the near future as well. But for now its working lightning-fast.
And just to mention it: The 100% correct way would be to change to tvtv.co.uk in xml as well including changed files names. But I decided to make it quick and dirty so that you can leave the rest (incl your WebGrab++.config.xml) untouched. That means set everything as it was before for tvtv.de and just use the new tvtv.de.ini (don't forget to rename the downloaded file to that...)
Furthermore I changed the way to display series episodes to: S02E06/10 (Season 2, Episode 6 out of 10).
Don't forget that this is only an bushfix. If you want an solution for current tvtv.de site I guess Blackbear199 has an more professional solution for you.

Some additional words. This method is NOT working anymore!
Please think about to donor and use Blackbear199's solution.
Same did I. Time to support these guys! :-)

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

@Blackbear199

Now I use your updated tvtv.de.ini but I have an wired issue:
Some/most channels are working but I found out that for instance RTL II gives me wrong EPG Data:
Today is 01.11.2018 but the ini grabs data from 18.11.2018 and set it to 01.11.2018 in guide.xml.

As an example take a look at movie "20:15 Der Staatsfeind Nr. 1" which is sheduled for 20:15 18.11.2018 on TVTV.de webpage but in guide.xml it listed for today (01.11.2018)

Enclosed resulting guide.xml and my config.xml (for tests I stript it down to grab only 3 channels).
The tvtv.de.ini is not posted as its from donors area - In this I removed only one line to get one digit movie rating (removed: "starrating.modify {calculate(not "" format=F1)}") which is needed for my EPG. Rest is untouched.

Please let me know if you need more data...

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Hi @ all,

fluffi444 wrote:

@Blackbear199
Now I use your updated tvtv.de.ini but I have an wired issue:
Some/most channels are working but I found out that for instance RTL II gives me wrong EPG Data:
Today is 01.11.2018 but the ini grabs data from 18.11.2018 and set it to 01.11.2018 in guide.xml.
As an example take a look at movie "20:15 Der Staatsfeind Nr. 1" which is sheduled for 20:15 18.11.2018 on TVTV.de webpage but in guide.xml it listed for today (01.11.2018)

The same here.
I checked at rondom such as Das Erste, ZDF, RTL and so on. They looks ok.

If help needed, let me know!

Btw.:
The ini works great, I'm happy with that one!

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Thanks a lot for the new ini!
I have to wait until it will be done and I'm able to check, because my computer isn't that fast :-))

jam
Offline
Donator
Joined: 10 years
Last seen: 3 years

@Blackbear199
Using @Revision 14 is only for 2.1.5 which - for some reason - does not support "premiere" extraction. Would be great if you can either enable "premiere" in 2.1.5 or revert revision back to 2.1.

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

Works! Perfect! Thx for the fast fix!

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

Nice to hear! Glad to help!

And sorry... Found other issue(s) - But this time some TV Shows were left out:

Everything for today: 01.11.2018

Pro7 MAXX (on TVTV web)
19:20 - 19.45 Futurama
19:45 - 20:15 Family Guy
But in guide.xml
19:20 - 20.15 Futurama

Kabel eins (on TVTV web)
17:50 - 18:20 Shrek Halloween Spezial – Er-Shrek dich nicht!
18:20 - 20:15 Bedtime Stories
But in guide.xml
17:50 - 20:15 Shrek Halloween Spezial

Sixx (on TVTV web)
18:35 - 19:20 Crazy Clips
19:20 - 20:15 Crazy Clips
But in guide.xml
18:35 - 20:15 Crazy Clips

SAT 1 (on TVTV web)
18:30 - 19:00 Alles oder Nichts
19:00 - 19:55 Genial daneben – das Quiz
19:55 - 20:15 SAT.1 Nachrichten
But in guide.xml
18:30 - 20:15 Alles oder Nichts

SAT 1 Gold (on TVTV web)
19:25 - 19:45 K 11 – Kommissare im Einsatz
19:45 - 20:15 K 11 – Kommissare im Einsatz
But in guide.xml
19:25 - 20:15 K 11 (this shows only as "K 11")

This is all I found in my 20 Channel list. And of course only for current time.
Furthermore it looks like that Titles with dash as seperator having issues:
K 11 – Kommissare im Einsatz -> K 11
Berlin - Tag und Nacht -> Berlin
Shrek Halloween Spezial – Er-Shrek dich nicht! -> Shrek Halloween Spezial

Maybe I missed something - Will keep my eyes open...

Attachments: 
turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

I'm sorry, I downloaded the old Version of the ini file (rev.13)
Can't find the new one, is that a special link?

Someone able to help me pls.

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

@ Blackbear199
Thanks a lot!
I Think, the problem is always the same name of file!
So my Firefox take's it out of the cash ... :-(
I got it now with a different PC und I used Opera ...

Is there now a new one again, so I have to download it ones more?

I have one more Question:
Is it possible to split the "NDR Deutschland" also in regional?

Thanks for the excellent Support!!

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Hello "RBB" and "SWR" I found!
But not NDR ...
That's why I'm asking.
There is only one line "NDR Deutschland"

I also don't know if it's possible to do so for NDR also ...
It's just a Question!

Or do I have again an Old File?
The channel.xml is from today 20:53

turbo112
Offline
Donator
Joined: 5 years
Last seen: 4 months

Thanks a lot for your Support!!!
I'll download it now and see how it works out.
But I think I have to do that on the WE ...

I'll post my experience

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

You are the master! Thanks again!

Understand how this works and understand the new part of the code.
It dindn't came to my mind that those channels are broadcasting different "regional" TV shows.
But after your post it comes more clear.

Is there a way to find out which channels are having this local behaviour? Tried to find it for myself on tvtv webpage but didn't succeed up to now. I guess there could be more of those. Pro7 is an candidate as well. As faar as I know they broadcasting different TV shows for Austria (for instance) as well...

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

OK - Did exactly this for myself for Pro7. But good to know that my code is the same as yours. :-)

And big thanks for that hit regarding the localization on TVTV.de - Didn't notice this regional mark above some shows. I think we did it for now - Everything else is easy to reproduce!

Perfect support dude!

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

2 more with regionals "Deutschland" - did a quick check over all tvtv.de channels for Germany.
-> RTL
-> Super RTL

Updated ini and xml for myself... ;-)

And thx for your offer. Will get back to you if there are any topics.
Up to now I'm more than happy that tvtv.de grabbing is working again. Thanks to you.

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

Thanks to you for your endless support! Yeah - missed ORF because they are Austrian. ;-)

Didn't find anything else! This ini seans to be finished...

Maybe interesting for some others as well:
MTV now send on NICK channel starting 20:15 each day - Note that xmltv_id and naming could be different of your EPG device settings - See picture for WebGrab++.config entries

Attachments: 
DJS
Offline
Has donated long time ago
Joined: 5 years
Last seen: 5 years

Since updating tvtv.de.ini from Revision 9 to 15 I wonder how I can change the output to
episodesystem xmltv_ns
Any simple solution out there?
Thanx in advance

DJS
Offline
Has donated long time ago
Joined: 5 years
Last seen: 5 years

Yes it works after updating from 2.1 to 2.1.5, deleting guide.xml and creating a new one.
Thanx :-)

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

Hey Blackbear,

is there a simple solution to change Episode/Season (of tvtv.de.ini latest)
from: S2 E18/20
to: S02E18/20

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

No problem! I happy as it is right now! :-)
Thanks anyway that you took a look into it!

antagon5
Offline
Donator
Joined: 5 years
Last seen: 1 month

Hello guys,
obviously there is already a Revision15. I got Revision13 in October from Blackbear199. I cannot find where to download the new revision. Old links and the new section for site.inis in the forum didn't work. Can anyone give me some help? Thank you in advance.

level20peon
Offline
Joined: 5 years
Last seen: 3 months

Hello, I donated but cannot find any tvtv.de.ini in either of those forums (although I can see them):
http://webgrabplus.com/forums/europe
http://webgrabplus.com/forums/new-updates

The latest ini I *can* access is version 9 here:
https://github.com/awiouy/webgrabplus/blob/master/config/siteini.pack/Ge...

Please advise on how to obtain the latest version of the tvtv.de.ini.

level20peon
Offline
Joined: 5 years
Last seen: 3 months

Is this forum still active?

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

@Blackbear199

Is there any reason why all your posts in this thread and your tvtv.ini file (in donors area) is away?

@level20peon

Yes - this is strange - I made a good discussion with Blackbear199 here but all this post are deleted here (but he is still active in WebGrabber forum) - Don't know what happened!

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 28 min

http://www.webgrabplus.com/comment/15798#comment-15798

Basically it is not correct that 95% of the users (or may be abusers?) with 5€ donation was accessing all the site.ini.
We asked the authors to change the way was running and we are waiting for an action.

level20peon
Offline
Joined: 5 years
Last seen: 3 months

I read that post and understand what's happening.

Is anybody who is still active on here able to provide the latest tvtv.ini though? To be frank, I don't have any use for webgrab plus if I cannot parse this site.

fluffi444
Offline
Joined: 5 years
Last seen: 1 year

@mat8861 - Thanks for pointing me to that direction. Sad to read that whole story...
To be honest - I know this kind of discussions from other 'former' open source projects.

I hope that you become friends again in future and the WebGrabber Project will not die.
As someone elso already said: WebGrabber is nothing without updated ini's.

Anyway - I do not know you guys well. But Blackbear199 helped me alot with ideas and fixing the tvtv ini...

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 week

i sent him the ini..contrary to my beliefs but i think he is a honest user.

Pages

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl