You are here

Request .ini rede globo

29 posts / 0 new
Last post
FABRICIOAMORIN2803
Offline
Donator
Joined: 5 years
Last seen: 2 weeks
Request .ini rede globo

Would it be possible to .ini the Globo network with all affiliates?

https://redeglobo.globo.com/sao-paulo/programacao/#202101241

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 day

Added to brazil (thanks to BB)

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
mat8861 wrote:

Added to brazil (thanks to BB)

Hi, do you know if you have a problem? It's not working for me

[ Info ] ( 52/255 ) REDEGLOBO.GLOBO.COM -- chan. (xmltv_id=Tvfronteira.br) -- mode Smart
[ Debug ] skipped show without a title at 07/02/2023 07:00:00
[ Debug ] skipped show without a title at 07/02/2023 09:00:00
[ Debug ] skipped show without a title at 07/02/2023 10:32:00
[ Info ] Summary for update of Tvfronteira.br
[ Info ] no changes, no update necessary !
[ Info ] unchanged shows inspected 0
[ Info ] total after update 0

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

its a ini problem,will have a look

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

fixed.

Updated: Apr 9/2023

Attachments: 
rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

fixed.

Thanks Blackbear199

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

fixed.

Hi, the ini seems to be having problems again, here it is not generating the programming.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

fixed.
edit the ini and set the timezone= to the same timezone as the pc running webgrab.
the site returns times in users local time.
use timezone=?
run webgrab
check log file for list valid timezone settings if you dont know what to use.

files updated in above post.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

noticed sometimes actors are separated with a ;
change this line(add separator=";") or dlowload files again.
index_actor.scrub {multi(max=8 separator=";")|"cast":[|"name":"|"}|]}

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

noticed sometimes actors are separated with a ;
change this line(add separator=";") or dlowload files again.
index_actor.scrub {multi(max=8 separator=";")|"cast":[|"name":"|"}|]}

Thanks Blackbear, this works now!

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

noticed a problem with the showsplit.
the first show of every day was missing.
files updated in above post.

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

noticed a problem with the showsplit.
the first show of every day was missing.
files updated in above post.

Hi, the guide is working, but I've been trying for a few days now, and no matter how much I change the time zone, it's always the same schedule.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

not sure what you mean.
its the same channel everywhere isnt it?
provide specific examples.

you need to set the timezone to that of the pc running webgrab as brazil has a few different timezones.

example,same show but because of the location the start time is different..

<programme start="20230408000500 -0300" stop="20230408005500 -0300" channel="Regionais - são paulo">
<title lang="pt">Jornal da Globo</title>

<programme start="20230408010500 -0300" stop="20230408015500 -0300" channel="Rede Amazônica - acre">
<title lang="pt">Jornal da Globo</title>

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

actually if you compare the epg for these 2 regions its not all the same,there are differences.

Attachments: 
rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

not sure what you mean.
its the same channel everywhere isnt it?
provide specific examples.
you need to set the timezone to that of the pc running webgrab as brazil has a few different timezones.
example,same show but because of the location the start time is different..
<programme start="20230408000500 -0300" stop="20230408005500 -0300" channel="Regionais - são paulo">
<title lang="pt">Jornal da Globo</title>
<programme start="20230408010500 -0300" stop="20230408015500 -0300" channel="Rede Amazônica - acre">
<title lang="pt">Jornal da Globo</title>

I wasn't very specific, sorry, what I mean is that no matter how much I change the time zone, the schedule at that exact moment remains the same. Example: Now 'Caldeirão com Mion' is playing but in the Guide it always shows "Amor Perfeito". Even changing to another region does not change. It always stays 3 hours longer than the actual schedule.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

are you using the new channel list?
i dont remember what the previous one was like.
upload your guide.xml

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

i just checked the 2 above channels with the site and the data is correct.
Caldeirão com Mion is playing in sau paulo
Paixão de Cristo is playing in acre

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

are you using the new channel list?
i dont remember what the previous one was like.
upload your guide.xml

Attachments: 
Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

i see nothing wrong,your epg matches the site.
some channels have the same programming while others are different.

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

i see nothing wrong,your epg matches the site.
some channels have the same programming while others are different.

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

i see nothing wrong,your epg matches the site.
some channels have the same programming while others are different.

I'm generating the programming on a VPS in Seattle/USA, before it was working normally.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

so what timezone is this vps using?
thats the timezone you need to set in the ini,i'm sure its not utc-03:00
west coast timezone would be America/Vancouver or America/Los_Angeles

ssh into your vps and type date and hit enter.
it will tell you the timezone the system is using.
example for me..
bb199:/raid/NAS_WebGrab# date
Sat Apr 8 16:51:01 ADT 2023

ADT is UTC-0300 which the ini is set to because thats what i use.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

also u cannot compare a new ini to a previous one.
anything and everything can change on a site.
thats why i specifically said you need to set the timezone to that of the pc running webgrab.
do it or dont.dont expect the correct results if you dont.

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

so what timezone is this vps using?
thats the timezone you need to set in the ini,i'm sure its not utc-03:00
west coast timezone would be America/Vancouver or America/Los_Angeles
ssh into your vps and type date and hit enter.
it will tell you the timezone the system is using.

example for me..
bb199:/raid/NAS_WebGrab# date
Sat Apr 8 16:51:01 ADT 2023
ADT is UTC-0300 which the ini is set to because thats what i use.

My timezone is -0300 Brasilia/Brazil

Attachments: 
Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

epg matches the site from what i can tell.
again,need specific examples of where your seeing different.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

ok,i had a very close look at the data and see a major problem.
not even sure if it can be fixed.
will let you know.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

see if this matches your streams
edit: link removed
files updated in above post,i dont think there's anything more that can be done if its still incorrect.

rhalima92
Offline
rhalima92's picture
Donator
Joined: 8 years
Last seen: 1 week
Blackbear199 wrote:

see if this matches your streams
edit: link removed
files updated in above post,i dont think there's anything more that can be done if its still incorrect.

It's very strange, I can't understand what happens, apparently everything is normal in the tab, but in the application it is always ahead.

My guide: http://epg.rhaflix.com/globo/epg.xml

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

i forgot the mention the site doesnt show the times in users local time.
it shows them in the local timezone of the channel.
so if...
the local timezone of the channel is utc-0500
your local timezone is utc-0300
webgrab will show this show 2 he ahead of what the site shows.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl