You are here

please create siteini for georgian tv site, (https://tv.mar.tv) and (https://silktv.ge/)

44 posts / 0 new
Last post
Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days
please create siteini for georgian tv site, (https://tv.mar.tv) and (https://silktv.ge/)

Hello! Please create siteini for Georgian tv sites, (https://tv.mar.tv) and (https://silktv.ge) . Thank you!

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

done.
will be added to siteini.pack some time today.
for mar.tv you need to edit the ini and set the timezone= to your local timezone,read the remarks at the top of ini.

Attachments: 
Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

thank you very much, I donated 5 euros to you, the license is not active yet, as far as I understand

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

i just check and the paypal transaction hasnt been recieved yet.
i will keep checking and activate it as soon as it arrives.

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Okay, I left a photo of the receipt here, just in case.

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

ok.thks.the system downloads it directly from paypal
sometimes there a delay before paypal posts it so the system can download it.

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Okay, thanks

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

your good to go.

Artiom007 : new expiry date 2024-03-17
update success !!

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Very good, thank you!

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

how long should i wait after activation? For example, now the program still recognizes me as a subscriber with a free license

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

your license line is disabled by default.
remove the <!-- and --> from the beginning and end.

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

also your password is not your forums password,scroll to the bottom of the page and on the right click on my account.
you will see a passcode,use that for password.

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Now works, okay!

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

and how can I make that the names of the sites were not displayed in the output epg file? for example this https://myvideo.ge

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

edit the ini and on the site {xxx} remove the name from the url=xxx
site {url=|[rest of settings}

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

i just tried that and looks like it didnt work,i thought it used to.

if your using linux you can use sed after webgrab completes.

sed -i "/<url/d" /path/to/filename.xml

you can add this to the run.sh or run.net.sh file for webgrab
scroll to the bottom and add it before the quit 0 line.

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

I use it on Windows, because on Ubuntu for some reason it gives an error I can’t run your program normally at all, the config is exactly the same, only the path changed and nothing else was touched. If you help me fix it on Ubuntu 18 I will be very grateful, .wg++ folder I have in /root/. Please look my screenshots. I haven't added anything to run.sh yet, everything is default

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

try changing your dns to google
8.8.8.8 and 8.8.4.4

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

please also make an .ini for this site https://www.magticom.ge/en/tv/tv-services/tv-guide , there is an epg for almost all Georgian channels, there is a choice by category, if possible I am most interested in Categories Sport and Georgian

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Or if you have Magticom in your packet, please update, there will be new channels, for example Setanta Sports 1,2,3

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

users can create updated channel lists themselves.
http://webgrabplus.com/documentation/configuration/sitechannelsxml
<update>c</update>
is usually all thats needed.
some ini are more complicated,always open the ini and check the remarks near the top for any special instructions.

Edit: files updated 19 mar 2023

Attachments: 
Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

regarding Magticom.ge, I noticed such a problem, for some reason the TV program is parsed only starting from 15:00 or 15:30 in the case when information is available on the site from 02:00 - 04:00, here are examples. Not only one channel is like that, all channels taken from magticom have this problem...

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

fixed,files updated in post above.

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

and there is such a command to replace
to my text?

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

I mean it

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

using sed
sed -i 's/<tv[^<]*>/<tv whatever you wish>/' guide.xml

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Thank you!

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Hello! I noticed that the channels from silktv.ge have some problems, it happens that they don’t update the TV program at all, it happens that the EPG is updated but only for a few hours and that’s it, I left screenshots of errors here, please look. myvideo.ge and magticom.ge is ok, no problem there

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

i wasnt able to reproduce this error but i made some changes.
try revision 3.
if you still get the error provide the site_id="xxx" for the channel.

Attachments: 
Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

thank you, now there is no such error yet

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

I'm also wondering, do you have the ability to parse EPG from android applications? I am interested in this for Armenian channels.

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

your should start a new post for a different topic.
what are the channels and app?

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Ok, I will start a new topic later and describe which channels and applications there

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Hello! Last time I applied about the fact that the application does not start on Ubuntu 18, I changed the DNS but it did not help, Mono JIT compiler version 6.12.0.182. I will leave screenshots and a log file below, I will also note that I tried it on ubuntu 20 and it also does not work there but the same config xml on my Windows works without problems

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

try..
sudo update-ca-certificates

i dont know why but lately alot of users are having issues with V3.x on linux and osx
i suggest you try V5.x which uses dotnet instead of mono.

see post #5 here.
http://webgrabplus.com/content/osx-install-procedure-outdated#comment-32002

thi is in a osx topic but the procedure is the same for linux.

for dotnet ubuntu install
https://learn.microsoft.com/en-us/dotnet/core/install/linux-ubuntu

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

thanks, all problems are solved. It just turned out that there is no access to myvideo.ge from my German server, so far I have replaced what I could with EPG from Magticom.ge

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

Hello! What could be the reason that half of the channels from magticom.ge are not updated? I look, they have EPG on the site for channels that are not updated for me, plus the worst thing is that yesterday there was an EPG for these channels, and today after the update, everything related to these channels disappeared from my xml, that is, he deleted the old one information about these channels... for example please look the screenshots, I tried to write in "uptate" i, c, f, l, but the situation has not changed

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

i need logs and config files(remove your license info).
include your last guide.xml

i cant tell much from your screenshots as you have translated the channels names to english and i cant grab the data to verify its there as i have no clue what the channel site_id="xx" is and i have no plans to learn georgian.

still not fully sure what your asking.
i checked a few channels and the data looks fine.

are your changing the update mode in <update>x</update>
what i would do is leave this empty.
<update></update>

webgrab will use the update mode of each channel line which is update="i" by default.
i is incrimental mode.
updates mode explained here..
http://webgrabplus.com/documentation/configuration/webgrabconfigxml#conf...

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 24 sec

i forgot to mention also
if you have a update mode set in <update></update>
it overrides any channel update="x" setting.

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

After running the script several times, EPG appeared on almost all channels, but for some reason only two channels still give an error - no shows in indexpage! Log file - https://dropmefiles.com/AClыkT (The specified file WebGrab.log_.txt could not be uploaded. The file is 2.49 MB exceeding the maximum file size of 2 MB.)

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

and this guide xml

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 25 sec

fixed.
the epg grabbing start date was being calculated incorrectly due to a missing )

magticom.ge revision 4

Attachments: 
Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 25 sec

also change your timeout setting in your config to 30
the default is 5 and is too low.
time-out="30" on the <retry line

Artiom007
Offline
Donator
Joined: 11 months
Last seen: 3 days

thanks, now all channels have updated successfully, timeout changed to 30 as you said

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl