You are here

foxtel.com.au.EK failing with "The authentication or decryption has failed"

26 posts / 0 new
Last post
Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks
foxtel.com.au.EK failing with "The authentication or decryption has failed"

Hello,

I have used the key and the 2 files from the donator forum, on webgrab v3, and i get the above error when running.

Files attached, and help would be awesome.

Thanks

Attachments: 
Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 month
Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Hi Blackbear,

Ive done the mono thing, and thats all OK.

Im getting a different error now...attached.

Attachments: 
Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 month

try increasing your time-out setting in you wgconfig.xml from 5(I use 30).
other than that you will have to wait for mat to replay as he encrypted the file.
can you visit the website on this pc and view the tvguide?

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

ok, tried the timeout at 30 and no difference.

Site (https://www.foxtel.com.au/tv-guide/grid) works ok.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 month

do u happen to have a vpn turned on?

I had vpn on(usa server) and had issues grabbing(although not a timeout error like your getting).

update requested for - 1 - out of - 1 - channels for 1 day(s)
( 1/1 ) FOXTEL.COM.AU -- chan. (xmltv_id=13: Foxtel Movies Premiere HD) -- mode Force
i
error downloading page: The underlying connection was closed: An unexpected error occurred on a receive.
pausing 1 of 4 times for 30 seconds before re-try.

turned off vpn and it worked fine.
website loaded fine with vpn but for some reason its didn't like it for grabbing data.

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Nope, no vpn....below is what im seeing.

By chance, does it work for you?

update requested for - 1 - out of - 1 - channels for 4 day(s)
( 1/1 ) FOXTEL.COM.AU.EK -- chan. (xmltv_id=WA-Perth Foxtel Movies Premiere HD) -- mode Force
i
error downloading page: The operation has timed out. (30sec)
Retry 1 of 4 times
error downloading page: The operation has timed out. (60sec)
Retry 2 of 4 times
error downloading page: The operation has timed out. (90sec)
Retry 3 of 4 times
error downloading page: The operation has timed out. (120sec)
Retry 4 of 4 times
Unable to update channel WA-Perth Foxtel Movies Premiere HD
Generic syntax exception:
message:
no index page data received from WA-Perth Foxtel Movies Premiere HD
unable to update channel, try again later

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 month

the file in donators section doesn't work for me,same error u have.
it must be broken,mat will have to fix it.

earlier I was trying my own version and it worked.

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

ah well thats good both ways.

Is it worth sharing your version?

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

or Matt possibly fixing :-?

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

Revision 8? works fine here...what error do you have ? Could not find WA-Perth Foxtel Movies Premiere HD so
i produced a new list a new list site_id="24576_SOD" Foxtel Movies Premiere HD din't try the other but i grabbed 2 channels so works for me. Use the one in siteini.pack (just uploaded) or run update c and get a new list.

Attachments: 
Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Thanks Matt,

Im using the rev 8 from the normal download page a you suggested.

I grabbed the two files just now and added the encryption key and a channel into the WebGrab++.config.xml and ran webgrab.

I got timeouts......

So, i need to go back to basics i think. Are you able to post here siteini files you are using please, and then ill just add the donator key. If those files works for you, they should work for me right.

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

Always siteini pack, although download page is updated later. Run Update Siteini.pack or download here https://github.com/SilentButeo2/webgrabplus-siteinipack/tree/master/site...
PS
Updating channel list is left to the user so before trying make sure you run a new channel list with update c or the old method ,whatever is required.

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Thanks Matt,

I cant for life of me work out the new update c method, what the process?

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

Then a look on documentation is right for you!! http://www.webgrabplus.com/documentation/configuration/sitechannelsxml

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Call me a numpty, but im still lost.

How does "just run update_c This will work for site.ini with one block for channel generation and create channel list without modification to the site.ini file." mean? What exectly is added where? Full syntax from doco below....sorry for being a little slow.

As of WG++ version 2.1.7 you can just run update_c This will work for site.ini with one block for channel generation and create channel list without modification to the site.ini file. Viceversa "the old method" is enable .channels.xml generation in the siteini file
2. Add 1 dummy channel in to the WebGrab++.config.xml file + only configure to grab 1 day, example: Line sample
3. run WG++ once (this wil generate the your_site.channels.xml file)
4. disable the .channels.xml generation in the siteini file again

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Matt, im getting the same "error downloading page: The operation has timed out. (15sec)" error.

Maybe i need to run that updated channels list, but i need to guidance on the update c process. Sorry to be a pain.

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

Update "c" set in WebGrab++.config.xml means update channels (create a new channel list) obviously this is done without modifying the siteini, just add update c to your config, run wg one time and the list is created.Change to f,i or other modes to grab.
The old method, (where you can, meaning no encryption) you remove the * in front of the channel list block of the siteini, run wg and get the new channel list, after you need to re-add the * so it grabs shows and not channels.

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

No problem, do i need a dummy channel line in the config.xml, or is it left blank?

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

dummy or one exsisting, the important is to have in the channel line you add in config the siteini name like site="cosmote.gr" or site="foxtel.com.au.EK" in your case
One line is enough no need to add all channels ..even better timespan 0 (zero)

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Ok did that, i still get the website timeout even doing the channel list creation.

I must be doing something daft!

Ive attached the logfile hoping it helps expose my foolishness!

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

use in config retry time-out="60" 4

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

No difference Matt, still.....

Update requested for - 1 - out of - 1 - channels for 1 day(s)
( 1/1 ) FOXTEL.COM.AU.EK -- chan. (xmltv_id=dummy) -- mode Channellist
i
error downloading page: The operation has timed out. (60sec)
Retry 1 of 4 times

So, i assume this exact same config is working for you?

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 21 hours

weird timeout is returned by a request too fast or because dns. See if with nslookup you can resolve https://www.foxtel.com.au/index.html if not set your dns to 8.8.8.8

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

nslookup "https://www.foxtel.com.au/index.html"?

normally nslookup is only the domain part, which resolved fine......

scratching here....... Is it working for you?

Uthall
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

Matt....and this. Can you just post your working files so i can try them?

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl