You are here

Foxtel Australia site ini

29 posts / 0 new
Last post
aanda6
Offline
Joined: 8 years
Last seen: 6 years
Foxtel Australia site ini

Hi,

is there any chance you could create a site ini. for the actual Foxtel guide in Australia. It is more acurate than the current yourtv.com guide.

http://www.foxtel.com.au/whats-on/tv-guide/default.htm

 

Thx,

Andrew

 

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us

Nice site  ... I'll have a look ..

Jan

aanda6
Offline
Joined: 8 years
Last seen: 6 years

thx Jan,

 

btw i am very impressed with your software. wish i new about this years ago! it would have saved a lot of headaches with getting the guide in Australia

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us

Hi Aanda

 

don't get your expectations too high. Foxtel.com.au is a very tricky one. It uses a very rare http request protocol which we have only seen once before. With that one we succeeded but .. It might be impossible .. however, haven't given up already

 

Jan

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us

Hi

I made good progress, just the finishing touches! So, two questions:

  • What is your region. (I will make it for that first)
  • Ho do you like the episode :
    As on foxtel site  <episode-num system="onscreen">S8, Ep14</episode-num> or:
    In the xmltv_ns standard <episode-num system="xmltv_ns">7.13.</episode-num>

Jan

 

aanda6
Offline
Joined: 8 years
Last seen: 6 years

Hi Jan,

 

you  do amazing work.

my region in Melbourne

i prefer the xmls standard.

 

thx,

Andrew

 

philzgr8
Offline
Joined: 8 years
Last seen: 5 years

Hey Jan,

I am also in Melbourne and would also appreciate this very much.

Cheers,

Phil

aanda6
Offline
Joined: 8 years
Last seen: 6 years

Hi Jan,

 

hope this isn't too much of a problem but after consideration i prefer the way foxtel do it <episode-num system="onscreen">S8, Ep14</episode-num>

 

Thx

philzgr8
Offline
Joined: 8 years
Last seen: 5 years
aanda6 wrote:

Hi Jan,

 

hope this isn't too much of a problem but after consideration i prefer the way foxtel do it <episode-num system="onscreen">S8, Ep14</episode-num>

 

Thx

Hey Andrew, I got your email. Thanks for putting me onto this forum. If we can actually get the Foxtel guide it will be amazing. Yourtv is pretty good but they clearly don't get inside info on channel changes.

Cheers,

Phil

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us

Hi Phil and Aanda

 

I was very occupied with finishing the .. very complicated! .. SiteIni for Foxtel that I missed your last change of mind. So for now, I placed the version with xmltv_ns syntax of the episode in the collection http://www.webgrabplus.com/sites/default/files/download/ini/info/zip/Australia_foxtel.com.au.zip.

There is an info file to change the region settings.

You can remove the conversion to xmltv_ns section yourself by disabling (or removing)  these lines:

* conversion of episode to xmltv_ns
* temp_2 = season
* temp_3 = episode
* temp_4 = number of seasons
* temp_5 = number of episodes
temp_2.modify {remove|S}
temp_2.modify {calculate(not="" format=F0)|1 -}
temp_3.modify {calculate(not="" format=F0)|1 -}
episode.modify {clear}
episode.modify {addend('temp_2' not="")|'temp_2'}
episode.modify {addend('temp_4' not="")|/'temp_4'}
episode.modify {addend|.}
episode.modify {addend('temp_3' not="")|'temp_3'}
episode.modify {addend('temp_5' not="")|/'temp_5'}
episode.modify {addend|.}
episode.modify {clear(="..")}

To disable add a * as first character to each line.

You also need to change the episodesystem setting somewhere at the top from episodesystem=xmltv_ns into episodesystem=onscreen

enjoy    ..   Jan

P.S. Making this ini took me three full days behind the computer! My wife tells me she doesn't recognise my front side anymore! Consider a contribution to buy her a compensation!

 

philzgr8
Offline
Joined: 8 years
Last seen: 5 years

Awesome work Jan. I will try to get it set up today and let you know how it goes. Happy to make a donation if you can provide details of how I can do that.

Cheers,

Phil

Edit: Oops, I found your "Support Us" button but something went wrong when I tried to donate. Apparently I have to wait half an hour to see if the transaction went through so I will check later and rectify if it didn't.

aanda6
Offline
Joined: 8 years
Last seen: 6 years

Hi Jan,

I am more than happy to donate.

I am having an issue with the free to air channels in the guide all saying "no shows in indexpage!"

<channel update="i" site="foxtel.com.au" site_id="152" xmltv_id="Channel 9 Sydney">Channel 9 Sydney</channel>

 

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us

Hi Aanda

 

for that you need to set to Region Sydney  Bouquet=25184 SubBouquet=37 StateId=2. I did some experiments, it seems that StateId doesn't make any difference for this channel , the same results for 2, 7 and also 9.

You could try if 25184 - 37 - 9 convers all your stations (Its the default setting of the foxtel site and seems to list most stations). If you need more than one setting you have to make more than one version of the ini, for each region setting one. Of course you need to give them different names, like foxtel.com.au.sydney.ini etc. To use them you also need to adapt the channel call in the config file, like :

<channel update="i" site="foxtel.com.au.sydney" site_id="152" xmltv_id="Channel 9 Sydney">Channel 9 Sydney</channel>

 

Jan

aanda6
Offline
Joined: 8 years
Last seen: 6 years

Thanks Jan,

I have another source for those channels that i can use anyway so i may just remove them for now.

 

thx.

philzgr8
Offline
Joined: 8 years
Last seen: 5 years

Hi Andrew,

I would love to have a copy of the script if that's possible. Not that I'm sure how you use wget or a script at this stage but I guess I'll learn what I need. I have generally avoided using logos because I've always had trouble finding a full set but I imagine that foxtel has that. I'm also wondering if I can just put the URL into BSEPG to link to the logo rather than download it.

Also want to thank Jan for his work. Hope my donation was received.

Cheers,

Phil

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us
andrew_j_evans wrote:

Seemed to be 24hrs ahead!!

This type of error is very often caused by the first show on the index page occuring 'yesterday' . In case I overlooked this and without analysing it, can you try to change this line in the ini  :

site {url=foxtel.com.au|timezone=Australia/Melbourne|maxdays=14|cultureinfo=en-GB|charset=UTF-8|titlematchfactor=90}

into:

site {url=foxtel.com.au|timezone=Australia/Melbourne|maxdays=14|cultureinfo=en-GB|charset=UTF-8|titlematchfactor=90|firstshow=1}

If it doesn't work , als try a few other values like 2 or 3

 

Jan

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us
philzgr8 wrote:

Also want to thank Jan for his work. Hope my donation was received.

 

As you can see, your user logo now also shows the 'donation badge'. See http://www.webgrabplus.com/content/support-us. Thanks !!

Jan

philzgr8
Offline
Joined: 8 years
Last seen: 5 years
andrew_j_evans wrote:

Sure, no probs Phil.

 

I will send up a Zip. I have included a png file list and 2 scripts. Up to you what one to use (batch file or Powershell v4).

The batch file uses the wget that is already part of webgrab+plus & powershell uses a commandlet "Invoke-WebRequest " that is part of Powershell Version 4. Both scripts require the text list of png files - included in the zip file attached. A real basic readme is also included.

Basicly the text file "fox_png.txt" in read in by the script and appended to the base url http://www.foxtel.com.au/cms/fragments/fragment_epgflash/logos/ like so "http://www.foxtel.com.au/cms/fragments/fragment_epgflash/logos/1.png".

The script loops though until the end of file is reached. I initialy looped from 1 - 999 to grab all png's - quick and dirty!!

Maybe a dynamic list can be generated in the future.

Have fun.......

Cheers,

Andrew (Perth)

 

Thanks Andrew,

I tried adding a few logos but at this stage the function in BSEPG used to show the logos doesn't seem to be working. It probably has to do with the fact that I'm also using My Channel Logos to increase the lines in the guide. I may have to use My Channel Logos to get it to work I guess. I do like this set of logos better than what I've had access to in the past.

philzgr8
Offline
Joined: 8 years
Last seen: 5 years
WGMaker wrote:

philzgr8 wrote:

Also want to thank Jan for his work. Hope my donation was received.

 

As you can see, your user logo now also shows the 'donation badge'. See http://www.webgrabplus.com/content/support-us. Thanks !!

Jan

Thanks Jan, I hope it helps a little at least!

philzgr8
Offline
Joined: 8 years
Last seen: 5 years
WGMaker wrote:

andrew_j_evans wrote:

Seemed to be 24hrs ahead!!

This type of error is very often caused by the first show on the index page occuring 'yesterday' . In case I overlooked this and without analysing it, can you try to change this line in the ini  :

site {url=foxtel.com.au|timezone=Australia/Melbourne|maxdays=14|cultureinfo=en-GB|charset=UTF-8|titlematchfactor=90}

into:

site {url=foxtel.com.au|timezone=Australia/Melbourne|maxdays=14|cultureinfo=en-GB|charset=UTF-8|titlematchfactor=90|firstshow=1}

If it doesn't work , als try a few other values like 2 or 3

 

Jan

Brilliant Jan,

I had noticed that one of my channels was a day out and tried your fix. Whilst I haven't specifically checked every channel for the same issue, using firstshow=1 definitely fixed the channel I had problems with.

Cheers,

Phil

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 9 hours
Is the support helpful?
support us

Phil (and other users of Foxtel)

 

there is a revision with the firstshow=1 addition in the collection http://www.webgrabplus.com/sites/default/files/download/ini/info/SiteIni.Pack/Australia/foxtel.com.au.ini

 

enjoy     Jan

bands
Offline
Joined: 8 years
Last seen: 4 years

G'day Andrew,

A couple of things, did you find that the fix worked for Perth 24hrs behind issue ?  Unfortunately nothing I did changed it, no biggie though as, like you, I just use Melbourne's list and change it via BigScreen EPG. Strange that Melb works but not Perth, but no drama, just curious if you got it to work.

The other thing was the logo's you mentioned. I can't find the location you indicated. Does this still work for you or have they been moved since you indicated where they are ?  If so, you don't happen to have a copy of them you can send to me do you ? 

Cheers .... Brad

EDIT: Apologies, I should have thanked all those involved with the development and upkeep of this great program. It looks like it could be the answer I am after and if so then I will be hitting the Donate button as well !! Cheers ...

philzgr8
Offline
Joined: 8 years
Last seen: 5 years

Jan,

Everything has being going well since includding the firstshow setting so I am very happy. One thing I am finding and I'm not sure why it is happening is that I find the synopsis information is repeated. I suppose it could have to do with the application I am using to import the data but it would seem a bit unlikely since I import data from another input without this issue. Any Ideas?

Thanks in advance.

francis
Offline
francis's picture
Has donated long time agoWG++ Team member
Joined: 10 years
Last seen: 6 months
Is the support helpful?
support us

damof,

Thanks for your findings. I have adjusted the .ini with your suggestion and have made the .ini more flexible. It is now easier to adjust for your region.

Just check the foxtel.com.au_info.txt file on how you can do it now.

Thanks and enjoy!

philzgr8
Offline
Joined: 8 years
Last seen: 5 years

I have just updated my site ini file to the latest one here but I am still finding that the episode description is duplicated. Below is an extract from my output xml to show what I mean. I have bolded the duplicated text. Is there a way to prevent this?

  <programme start="20150523193000 +1000" stop="20150523203000 +1000" channel="Universal">
    <title lang="en">Law &amp; Order: SVU</title>
    <sub-title lang="en">Haunted</sub-title>
    <desc lang="en">Haunted: When Fin is seriously injured in a shootout at the bodega, the ensuing publicity leads him to resolve a case from his past. When Fin is seriously injured in a shootout at the bodega, the ensuing publicity leads him to resolve a case from his past(n)</desc>
    <credits>
      <director>Juan J. Campanella</director>
      <actor>Dann Florek</actor>
      <actor>Ned Eisenberg</actor>
      <actor>Mariska Hargitay</actor>
      <actor>B.D. Wong</actor>
      <actor>Christopher Meloni</actor>
      <actor>Ice-T</actor>
      <actor>Diane Neal</actor>
    </credits>
    <date>2004</date>
    <category lang="en">Entertainment</category>
    <category lang="en">Drama</category>
    <episode-num system="onscreen">S6, Ep10</episode-num>
    <rating system="ACB">
      <value>MA</value>
    </rating>
  </programme>

 

 

aanda6
Offline
Joined: 8 years
Last seen: 6 years

Andrew_J_Evans any chance you can get your script to grab logos from the new guide page. Foxtel have changed the logos and they look better in my opinion.

aanda6
Offline
Joined: 8 years
Last seen: 6 years

thanks for that, not sure what I am doing with powershell but keep getting errors.

 

aanda6
Offline
Joined: 8 years
Last seen: 6 years

I cant run v4 of powershell as I do noty have service pack installed for win 7 as it kills my setup, any chance you coud make a batch file again. Sorry about that, but my HTPC is too critical to stuff around with again, last time I lost days re-installing everything.

mitchell.ross
Offline
Joined: 7 years
Last seen: 6 years

Andrew - many thanks for sharing this. Very generous. For those interested, I'd like to share my TXT file that works with Andrew's batch script and points to the slightly larger logos from the new site. I've gone with channel name for the PNG filename - as this matches up better on Kodi.

All credit goes to Andrew for the smarts here - I've just done some grunt work in pulling together a different TXT file. I think I've ironed out most of the missed links. Please note that I'm about as computer literate as your average potato - always happy to hear feedback on whether there was an easier way!

Attachments: 
Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl