You are here

Error on new Synology version

22 posts / 0 new
Last post
frog
Offline
Donator
Joined: 3 months
Last seen: 1 month
Error on new Synology version

Hi,

I updated to v7.1-42661 on my Synology NAS and now webgrab doesn’t work any more. I get the following:

Checking License ..
Job finished at 17/06/2022 00:32:45 done in 58s

An error occurred while sending the request

at Microsoft.Azure.Storage.Core.Executor.Executor.ExecuteAsync[T] (Microsoft.Azure.Storage.Core.Executor.RESTCommand`1[T] cmd, Microsoft.Azure.Storage.RetryPolicies.IRetryPolicy policy, Microsoft.Azure.Storage.OperationContext operationContext, System.Threading.CancellationToken token) [0x0102f] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.Core.Executor.Executor+<>c__DisplayClass0_0`1[T].b__0 () [0x00022] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.Core.Util.CommonUtility.RunWithoutSynchronizationContext[T] (System.Func`1[TResult] actionToRun) [0x0000c] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.Core.Executor.Executor.ExecuteSync[T] (Microsoft.Azure.Storage.Core.Executor.RESTCommand`1[T] cmd, Microsoft.Azure.Storage.RetryPolicies.IRetryPolicy policy, Microsoft.Azure.Storage.OperationContext operationContext) [0x00033] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.File.CloudFile.Exists (Microsoft.Azure.Storage.File.FileRequestOptions options, Microsoft.Azure.Storage.OperationContext operationContext) [0x0001b] in <3de5008650604d479fb0aec50432ef1f>:0
at WG.common.azure.Azure_Access.DownloadFile (Microsoft.Azure.Storage.File.CloudFileDirectory cfd, System.String filename, System.String& content, System.DateTime& lastmodified, System.Boolean& pass) [0x0001e] in <6aadbdd0efe84032be6e00bcf67f786a>:0
at WG.common.azure.Azure_Access.DownloadFile (Microsoft.Azure.Storage.File.CloudFileDirectory cfd, System.String filename, System.String& content) [0x00000] in <6aadbdd0efe84032be6e00bcf67f786a>:0
at  .–..ctor (System.Collections.Generic.Dictionary`2[TKey,TValue] , System.Boolean , System.Boolean ) [0x0052a] in <129dec1b18b44cf8b0b8a855b00404bf>:0
at  . ..ctor (System.String ) [0x01381] in <129dec1b18b44cf8b0b8a855b00404bf>:0
at  .―.  (System.String[] ) [0x00351] in <129dec1b18b44cf8b0b8a855b00404bf>:0
Unhandled Exception
For detailed info, see log file /var/services/homes/nigelsmith/wegrab/.wg++/./WGLicense.log.txt
Execution stopped

Any ideas what is happening?

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

we might have an idea if you attach your webgrab.log

frog
Offline
Donator
Joined: 3 months
Last seen: 1 month

It tells you nothing….

[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V3.2.0.0
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 17/06/2022 15:41:27
[ Debug ]
[ Debug ] Running on: Unix 4.4.180.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ] Mono version: 5.20.1.34 (tarball Sun Jan 2 16:42:18 UTC 2022)
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: /var/services/homes/nigelsmith/wegrab/.wg++/./WebGrab++.config.xml
[ Info ] Checking License ..

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

it tells a lot...do understand why you guys do not attach a text file, anyway update wg++, 3.2.0 is not good.
Also in latest version here https://github.com/SilentButeo2/webgrabplus-siteinipack/tree/master/eval...
you can use dotnet (install first dotnet sdk 5.0) which do not use the heavy mono environment.
Last not least check your dns settings, make sure your linux system use google dns (i went crazy because latest version use netplan).

frog
Offline
Donator
Joined: 3 months
Last seen: 1 month

You guys :)

Well I've tried earlier versions including V3.1.7.1 and I'm getting the same error around Azure. Using Mono on Synology and not in a docker container.

Using Mono 5.20

Mono JIT compiler version 5.20.1.34 (tarball Sun Jan 2 16:42:18 UTC 2022)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: normal
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
Interpreter: yes
LLVM: supported, not enabled.
Suspend: hybrid
GC: sgen (concurrent by default)

Really not sure what is happening here...

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

Can you please try 3.2.3.7 https://github.com/SilentButeo2/webgrabplus-siteinipack/tree/master/eval...
and make sure you check dns is working properly ? The error "at. ..ctor (System.String )......at .―.  (System.String[] )" is most of the time due to wrong dns (Microsft azure address error because dns cannot be solved)

frog
Offline
Donator
Joined: 3 months
Last seen: 1 month

Thanks. I've now installed this version (just replaced the bin directory from the tar0, set the DNS of the Synology and my main router to 8.8.8.8, but still getting this error - at least it isn't the Azure failure any more!

[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V3.2.3.7
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings, Mat8861, Blackbear199 and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 19/06/2022 18:04:49
[ Debug ]
[ Debug ] Running on: Unix 4.4.180.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ] Mono version: 5.20.1.34 (tarball Sun Jan 2 16:42:18 UTC 2022)
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: /var/services/homes/nigelsmith/wegrab/.wg++/./WebGrab++.config.xml
[ Info ] Checking License ..
[ Info ] For License request/update data, see WGLicense.log.txt
[ ] Job finished at 19/06/2022 18:04:50 done in 0s
[Critical]
Object reference not set to an instance of an object
[Critical]
at . ..ctor (System.String ) [0x0138d] in :0
at .―.  (System.String[] ) [0x0034b] in :0
[Critical] Unhandled Exception
[Critical] For detailed info, see log file /var/services/homes/nigelsmith/wegrab/.wg++/./WebGrab++.log.txt
[Critical] Execution stopped

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

Please delete the .lic files under /home/yourusername/.local/share/WebGrab+Plus/License and /home/root/.local/share/WebGrab+Plus/License
set in config force license (just "f" in license line) and run wg++ as root

frog
Offline
Donator
Joined: 3 months
Last seen: 1 month

Right, I deleted the files for my username, but there aren’t any root user files (it’s a Synology NAS), forced the license and run run.sh as root, and now I’m back to the Azure errors!

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

I searched the forum and your error looks like certificate sync needed
http://webgrabplus.com/content/running-synology-70-virtual-machine

frog
Offline
Donator
Joined: 3 months
Last seen: 1 month

That looks like it mostly fixed it - though I have to run the run.sh as root otherwise I get the unhandled exception errors.

I guess then it wasn't a problem with WebGrab, but with Mono.

ApexDE
Offline
Joined: 4 years
Last seen: 1 month

Hi there! I try to get WG 3.2 on a synology with 7.1 running too. I stumble across the Azure problem also. Is there a fix/patch already?

I tried to sync the Certificates as suggested, but it didn‘t help.

(sudo /volume1/@appstore/mono/bin/cert-sync /etc/ssl/certs/ca-certificates.crt)

admin@Syno-Echo:/volume1/Temp/wg32$ ./run.sh

WebGrab+Plus/w MDB & REX Postprocess -- version V3.2.0.0

Jan van Straaten
Francis De Paemeleere

thanks to Paul Weterings and all the contributing users
--------------------------------------------------------------------------------

Job started at 01/07/2022 14:27:58
Checking License ..
Job finished at 01/07/2022 14:28:48 done in 50s

An error occurred while sending the request

at Microsoft.Azure.Storage.Core.Executor.Executor.ExecuteAsync[T] (Microsoft.Azure.Storage.Core.Executor.RESTCommand`1[T] cmd, Microsoft.Azure.Storage.RetryPolicies.IRetryPolicy policy, Microsoft.Azure.Storage.OperationContext operationContext, System.Threading.CancellationToken token) [0x0102f] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.Core.Executor.Executor+<>c__DisplayClass0_0`1[T].b__0 () [0x00022] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.Core.Util.CommonUtility.RunWithoutSynchronizationContext[T] (System.Func`1[TResult] actionToRun) [0x0000c] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.Core.Executor.Executor.ExecuteSync[T] (Microsoft.Azure.Storage.Core.Executor.RESTCommand`1[T] cmd, Microsoft.Azure.Storage.RetryPolicies.IRetryPolicy policy, Microsoft.Azure.Storage.OperationContext operationContext) [0x00033] in <00c0301026234a7aa9724ac14a67ce50>:0
at Microsoft.Azure.Storage.File.CloudFile.Exists (Microsoft.Azure.Storage.File.FileRequestOptions options, Microsoft.Azure.Storage.OperationContext operationContext) [0x0001b] in <3de5008650604d479fb0aec50432ef1f>:0
at WG.common.azure.Azure_Access.DownloadFile (Microsoft.Azure.Storage.File.CloudFileDirectory cfd, System.String filename, System.String& content, System.DateTime& lastmodified, System.Boolean& pass) [0x0001e] in <6aadbdd0efe84032be6e00bcf67f786a>:0
at WG.common.azure.Azure_Access.DownloadFile (Microsoft.Azure.Storage.File.CloudFileDirectory cfd, System.String filename, System.String& content) [0x00000] in <6aadbdd0efe84032be6e00bcf67f786a>:0
at .–..ctor (System.Collections.Generic.Dictionary`2[TKey,TValue] , System.Boolean , System.Boolean ) [0x0052a] in <129dec1b18b44cf8b0b8a855b00404bf>:0
at . ..ctor (System.String ) [0x01381] in <129dec1b18b44cf8b0b8a855b00404bf>:0
at .―.  (System.String[] ) [0x00351] in <129dec1b18b44cf8b0b8a855b00404bf>:0
Unhandled Exception
For detailed info, see log file /volume1/Temp/wg32/./WGLicense.log.txt
Execution stopped

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

Use a newer version, 3.2.0 was buggy, there is also a .dotnet (no mono) here https://github.com/SilentButeo2/webgrabplus-siteinipack/tree/master/eval...
or a new 3.2.5 here : http://webgrabplus.com/download/sw/v3.2.5

ApexDE
Offline
Joined: 4 years
Last seen: 1 month

Thanks for the headsup! I updated to 3.2.5 but still get errors, even a step further though ;)
I would like to try the dotnet version, but only dotnet6 runtime is available for my Synology NAS. Webgrabplus requires dotnet5 and refuses to work with the newer framework.

Any idea for that problem? :

WebGrab+Plus/w MDB & REX Postprocess -- version V3.2.5.0

Jan van Straaten
Francis De Paemeleere

thanks to Paul Weterings, Mat8861, Blackbear199 and all the contributing users
--------------------------------------------------------------------------------

Job started at 03/07/2022 20:23:07
Checking License ..
For License request/update data, see WGLicense.log.txt
Job finished at 03/07/2022 20:23:08 done in 1s

Object reference not set to an instance of an object

at  . ..ctor (System.String ) [0x0138d] in :0
at  .—.  (System.String[] ) [0x0034b] in :0
Unhandled Exception
For detailed info, see log file /volume1/Temp/wg32/./WebGrab++.log.txt
Execution stopped

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

Did you add license data and running as root ? Some users had problem because cert sync, see here
http://webgrabplus.com/content/object-reference-not-set-instance-object-2

ApexDE
Offline
Joined: 4 years
Last seen: 1 month

Hello! Yes, i added the licence key/data from the very beginning. It only seems to run as root, as you suggested. Sadly there is only a Net6 package for my NAS, not a Net5 package. BUT: i managed to get it up running on my raspberry, where a NET5 Package is available :) I guess i'll keep it running on my raspberry.
Thanks

Another Question: I just figured out that you are the maintainer of the tvinfo.de.ini. It is only useable with a donator_licence cause of V3 encryption?

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

Authors published a dotnet 6 here https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/eval...
Another question : answer is yes, but could be any other staff member... with version 3 there is whole change of how wg++ works including some calculations and other stuff.

ApexDE
Offline
Joined: 4 years
Last seen: 1 month

and thanks again for the headsup. I‘ll try the NET6 Version on the Synology :)

ApexDE
Offline
Joined: 4 years
Last seen: 1 month

@mat8861

One more question (sorry) , the encrypted inis leave me a bit confused: is it true that i can't use your tvinfo.de.ini as a registered user (with corresponding license) ?

wg++ refuses to proceed cause of encryption.

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

The attached explain, you should also have your WGlicense.txt in your folder. Right now you are a registred user, so you cannot run V3 and you also have limitation: delay, time/title/description only, no post-process, etc etc.
If you donate you get "donator_license", if you do not renew after 1 year you have "donator" status for 1 year.
If you need more channel you donate following the initial donation, so 250channels=5euro, 500=10, 750=15 and so on. Any change you need to communicate with authors, example you donate 10euro..they do not know if you want 250channels for 2 years or 500 channels for 1 year, so it's always better to send them an email.
Bye

Attachments: 
ApexDE
Offline
Joined: 4 years
Last seen: 1 month

i would switch if there was a „lifetime“ option. Did you consider such a step?

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 8 hours

You can contact the authors, but i do not think there is such option.
As explained you can go up with years...number of channels..basically you can say i want 10 years with 500 channels...=100euro

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl