You are here

directv.com Stopping Webgrab Completely

26 posts / 0 new
Last post
Rolica
Offline
Rolica's picture
Has donated long time ago
Joined: 6 years
Last seen: 3 years
directv.com Stopping Webgrab Completely

Hi there, woke up today to a guide that was stopped during the grab. Found this to be directv.com that was causing it.

Log file included below.

Im using the current directv.com.ini Revision 12
I can ping directv.com and www.directv.com without issue. I dont appear to be blocked. (I have however, also tried with VPN's too)
I have a valid cookie (zip 10001)

I cannot work out what has happened. I figured I would wait until the end of day to see. I was sure others would be on about the same thing but, I guess not. Is it really just me?

Can anyone help? Any suggestions? Thank you for reading.
 

Attachments: 
kjb85
Offline
Joined: 5 years
Last seen: 5 years

I have the same problem.

 

Can't grab from DirectTV at all.

 

Linux.

Attachments: 
Graburrz
Offline
Donator
Joined: 6 years
Last seen: 4 months

Just changed all my channel links from tvguide to directv last week.  Grabs have been fine until today.  Now the directv channel links are failing for me too with these errors:

  • [Critical] Unhandled Exception
  • [Critical]
  • Index was outside the bounds of the array.
  • [Critical]
  •    at WGconsole.Program.ConsoleApplication(String[] args)
  •    at WGconsole.Program.Main(String[] args)
  • [Critical] For detailed info, see log file C:\ProgramData\ServerCare\WebGrab\WebGrab++.log.txt
  • [Critical] Execution stopped

The directv.ini in the latest siteini.pack is identical from the one I'm using.  A new cookie don't help. I'm still running v1.1.1 with the Beta 56.27 patch.  Will be watching this thread.

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I have same issue from yesterday. :) Is htere any solution for this? Also I am unable to grab form tv.com. for tv.com there is no error just nothing updateed. Please help me to fix this issue. Error details in the attached images

Attachments: 
jamieewart75
Offline
Donator
Joined: 6 years
Last seen: 3 months

Hi,

i have installed XAMPP and have it running with PHP however i am now getting the following error on Diretv channels

[  Info  ] (  10/456 ) DIRECTV.COM -- chan. (xmltv_id=A&E (US) HD) -- mode Incremental
[Error   ] Unable to update channel A&E (US) HD
[Critical] Generic syntax exception:
[Critical]    message: 
[Error   ] no index page data received from A&E (US) HD
[Error   ] unable to update channel, try again later
[  Info  ] Existing guide data restored!
[  Debug ] 
[  Info  ] (  10/456 ) DIRECTV.COM -- chan. (xmltv_id=ABC NEWS HD) -- mode Incremental
[Error   ] Unable to update channel ABC NEWS HD
[Critical] Generic syntax exception:
[Critical]    message: 
[Error   ] no index page data received from ABC NEWS HD
[Error   ] unable to update channel, try again later
[  Info  ] Existing guide data restored!

this is using the new version 13 ini file.

any help would be appreciated.

Thanks

Jamie

jamieewart75
Offline
Donator
Joined: 6 years
Last seen: 3 months

hi,

as far as i can tell curl is enabled.

extension=php_curl.dll

I am also using the new version 13 file and still have my cookies.txt file

still getting the same error

Jamie

 

jamieewart75
Offline
Donator
Joined: 6 years
Last seen: 3 months

Hi

I have got it working thanks so much for all your help.

Jamie

 

jgrott33
Offline
Joined: 5 years
Last seen: 4 years

So when you say there are lots about getting the php working, what do i search for? I have downloaded your files, but don't understand what the php file is looking for. what do I put in for channel, date(guessing today), subpage. does this only work via a web page request or can it be run via cli?

Thanks,

jgrott33
Offline
Joined: 5 years
Last seen: 4 years

What in my ini do i edit? and where do I download this version 13 of directv.com.ini ?

jgrott33
Offline
Joined: 5 years
Last seen: 4 years

Sorry to be a pain, the only files in the zip are the xml and php. I have the php working, i tried to edit my own version 12 ini file. but on each channel i get, [Error   ] no shows in indexpage!

I tired this: url_index {url|http://127.0.0.1/directv_com.php?reqtype=1&channels=|channel|,&startTime=|urldate|%20|subpage|:00:00%20GMT&hours=12}

Total guessing at the reqtype.

Thanks

jgrott33
Offline
Joined: 5 years
Last seen: 4 years

That worked, Thank you!!!

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Sorry for new NOOB question....

 

I did follow all the reply here and install php, enable curl correctly in same server. Now I am confused about where to upload .php and new .ini file? I guess .php file have to update in /var/www/html    and .ini file have to update in wg++ folder. I am not sure so please help me to figure this out.

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Many thanks for your instruction to resolve directv.com issue. I did fix it by following your instruction. Your are too ccol !!!

Tim1980
Offline
Joined: 5 years
Last seen: 3 years

can someone help me i cant seam to get the xampp to run right still getting errors in webgrab 

Tim1980
Offline
Joined: 5 years
Last seen: 3 years

I installed xampp and i put the php file into the htdocs folder and then removed the ; for the php.ini file and then ran webgrab here is the log alos put the new directv ini file into the config file of webgrab

Attachments: 
Tim1980
Offline
Joined: 5 years
Last seen: 3 years

its on a external hard dirve and its running . I have to run the Tomcat not the apache wont start gives error 

 

strilen
Offline
Donator
Joined: 8 years
Last seen: 1 month

Hi,

Running WG in linux and got apache2, php5, curl installed.

New ini file in wg config folder and php file in var/www/html folder.

WG is running without errors but saying "no shows in indexpage!"

URL in PHP fil seems valid. Any ideas??

 

/Strilen

strilen
Offline
Donator
Joined: 8 years
Last seen: 1 month

Hi, From Access.log (var/log/apache2):

127.0.0.1 - - [07/Jun/2017:22:41:19 +0200] "GET /directv_com.php?channel=556&date=Tue%20Jun%2013%202017&subpage=18&reqtype=1 HTTP/1.1" 200 1736 "-" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; yie9)"

Error log dont show any statement related to this run...

 

/Strilen

strilen
Offline
Donator
Joined: 8 years
Last seen: 1 month

Hi,

Yes, got it all installed. Do I need to edit any php or curl files to make it work??

One notice, I need to add an "s" in ?channel= ...til ?channels= to make the URL work in a browser for manual verification

https://www.directv.com/json/channelschedule?channels=556&date=Tue%20Jun...

## EDIT ##

Got your angle, pasted your URL into the browser pointing to the Apache web server and got a blank page.

Server_IP/directv_com.php?channel=556&date=Tue%20Jun%2013%202017&subpage=18&reqtype=1

/Strilen

strilen
Offline
Donator
Joined: 8 years
Last seen: 1 month

Ahh... may it be that I need to activate https on the Apache2 ?? Just noticed that the PHP path is a HTTPS...

If I edit the URL to https://Server_IP/directv_com.php?channel=556&date=Tue Jun 13 2017&subpage=18&reqtype=1

I get a "unable to connect" and not the blank page...

/Strilen

strilen
Offline
Donator
Joined: 8 years
Last seen: 1 month

Hi,

Found the sucker... I had installed PHP5-cli not the full package of PHP5 only...

Once I added PHP5 it works :) Thanks for your inputs!

/Strilen

kjb85
Offline
Joined: 5 years
Last seen: 5 years

Hi Blackbear199,

Had this working fine for the past couple of weeks on linux with PHP however it seems to have stopped again. I have made no changed on my end.

 

[Critical] Unhandled Exception
[Critical] 
Array index is out of range.
[Critical] 
  at (wrapper stelemref) object:virt_stelemref_sealed_class (intptr,object)
  at WGconsole.SiteIni.UrlBuilder (System.String preloadorindex, WGconsole.ChannelToUpdate chan, Int32 day, Int32 pagenbr, Boolean subpage, WGconsole.Scrub scrub) [0x00000] in <filename unknown>:0 
  at WGconsole.Program.ConsoleApplication (System.String[] args) [0x00000] in <filename unknown>:0 
[Critical] For detailed info, see log file /home/pi/.wg++/WebGrab++.log.txt
[Critical] Execution stopped

Any idea what may be causing this now as it is stopping the entire grab?

 

Cheers 

strilen
Offline
Donator
Joined: 8 years
Last seen: 1 month

Mine still runs fine using the PHP (@Revision 13) as the file from this night was just reviewed.

/Strilen

kjb85
Offline
Joined: 5 years
Last seen: 5 years

Thanks Blackbear199

I'm still using Rev 13.

 

Problem appears to have corrected itself somehow and is working fine.

I'm dubious about updating the ini now incase it breaks again.

Cheers

ErikssonNet
Offline
Joined: 5 years
Last seen: 5 years

Hi.

 

I have downloded your ini file and php file but Im having trouble getting it to work.

 

I have webgrab+ on the same pc as my IIS server. The php file is in my htdocs and I replaced the directv.ini file in the webgrab folder. I have copied the cookie information and saved it to directv.com.cookies.txt. I have checked and curl is active in my php.ini. I have change the url adress in the ini file also. When starting to grab I get the error message: Error downloading page and it retries 4 times each 5s longer.

If I enter this in the browser I get an output
myip/directv_com.php?channel=256&date=Tue%4Jul%2017%202017&subpage=18&reqtype=1

Im using php7 could that be messing with Webgrab+?

This is from the logfile:
[  Info  ] (   1/40  ) DIRECTV.COM -- chan. (xmltv_id=AETV.us) -- mode Incremental
[Warning ] error downloading page: Den underliggande anslutningen stängdes: Ett oväntat fel uppstod vid skickande.
[Warning ] pausing 1 of 4 times for 5 seconds before re-try.
[Warning ] error downloading page: Den underliggande anslutningen stängdes: Ett oväntat fel uppstod vid skickande.
[Warning ] pausing 2 of 4 times for 10 seconds before re-try.
[Warning ] error downloading page: Den underliggande anslutningen stängdes: Ett oväntat fel uppstod vid skickande.
[Warning ] pausing 3 of 4 times for 15 seconds before re-try.
[Warning ] error downloading page: Den underliggande anslutningen stängdes: Ett oväntat fel uppstod vid skickande.
[Warning ] pausing 4 of 4 times for 20 seconds before re-try.
[        ] Job finished at 01/07/2017 09:20:54 done in 55s
[Critical] Unhandled Exception
[Critical] 
Indexet låg utanför gränserna för matrisen.
[Critical] 
   vid WGconsole.Program.ConsoleApplication(String[] args)
   vid WGconsole.Program.Main(String[] args)
[Critical] For detailed info, see log file C:\Users\ErikssonNet Web\AppData\Local\WebGrab+Plus\WebGrab++.log.txt
[Critical] Execution stopped

Kick4U
Offline
Donator
Joined: 4 years
Last seen: 2 years

So it took me a lot longer than I'd admit, but I fixed the DirecTV ini to pull director, producer and actors to assist in MDB postprocess.

 

Update: edited php file to fix channel creation under windows with cookies.

Attachments: 
Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl