You are here

[Critical] Unhandled Exception

18 posts / 0 new
Last post
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks
[Critical] Unhandled Exception

Suddently I got error downloading page: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure
[Warning ] pausing 1 of 4 times for 5 seconds before re-try.

 

Please check log file for details error.   I did install Apache and put dircttv file in right directory. Also enable culr. But still I get this error. I am using Linux Ubuntu with php5 please help me to fix this issue.

Attachments: 
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Thenks for your reply. When I try to update mono by following guide http://www.mono-project.com/download/#download-lin-ubuntu

I get following error

 

root@vps155939:~# apt-get install mono-complete
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-complete : Depends: mono-runtime (= 5.4.1.6-0xamarin1+ubuntu1604b1) but 3.2.8+dfsg-4ubuntu1.                           1 is to be installed
                 Depends: mono-runtime-sgen (= 5.4.1.6-0xamarin1+ubuntu1604b1) but 3.2.8+dfsg-4ubu                           ntu1.1 is to be installed
                 Depends: mono-utils (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be                            installed
                 Depends: mono-devel (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be                            installed
                 Depends: mono-mcs (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be in                           stalled
                 Depends: mono-roslyn (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be                            installed
                 Depends: mono-csharp-shell (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going                            to be installed
                 Depends: mono-4.0-gac (= 5.4.1.6-0xamarin1+ubuntu1604b1) but 3.2.8+dfsg-4ubuntu1.                           1 is to be installed
                 Depends: mono-4.0-service (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going                            to be installed
                 Depends: monodoc-base (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to b                           e installed
                 Depends: monodoc-manual (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to                            be installed
                 Depends: libmono-cil-dev (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going t                           o be installed
                 Depends: ca-certificates-mono (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not go                           ing to be installed
E: Unable to correct problems, you have held broken packages.

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

root@vps155939:~# apt-get install mono-complete
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-complete : Depends: mono-runtime (= 5.4.1.6-0xamarin1+ubuntu1604b1) but 3.2.8+dfsg-4ubuntu1.1 is to be installed
                 Depends: mono-runtime-sgen (= 5.4.1.6-0xamarin1+ubuntu1604b1) but 3.2.8+dfsg-4ubuntu1.1 is to be installed
                 Depends: mono-utils (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: mono-devel (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: mono-mcs (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: mono-roslyn (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: mono-csharp-shell (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: mono-4.0-gac (= 5.4.1.6-0xamarin1+ubuntu1604b1) but 3.2.8+dfsg-4ubuntu1.1 is to be installed
                 Depends: mono-4.0-service (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: monodoc-base (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: monodoc-manual (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: libmono-cil-dev (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
                 Depends: ca-certificates-mono (= 5.4.1.6-0xamarin1+ubuntu1604b1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@vps155939:~#

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

It was Ubuntu 14.04 but now I am upgrading to Ubuntu 16.04 and will install mono with latest version. Let's see it fix or not. i will update you here when done. Thanks for your reply.

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I did upgrade to Ubuntu 16.04 and install mono

 

 mono -V
Mono JIT compiler version 4.2.1 (Debian 4.2.1.102+dfsg2-7ubuntu4)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen

 

 

But now I am confused about where in .ini file I have to add this line  "url's(url_index,index_urlshow,ect)"

 

Please guide me to fix this. Thanks

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Thanks for  your reply. Please check attached file for my .ini file . please cehck it.

Attachments: 
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Previous error fixed bu now another issue

No show in index page.  I get in every ch. Please check in attached file for log

Attachments: 
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Thanks for your reply. Yes i have <user-agent>

 

  <filename>guide.xml</filename>
  <mode></mode>
  <postprocess grab="y" run="n">mdb</postprocess>
  <user-agent>Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/51.0</user-agent>
  <logging>on</logging>
  <retry time-out="5">4</retry>
  <timespan>1</timespan>
  <update>f</update>

 

not only TV.com but also direct tv also giving no show in index page

 

TV.com is currently not working with WG++ ?

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I did get direct.tv.channels.xml file form your web iste. Yes I am using correct ckkies. check attached file fr cookies file. let me know If cokies file is wrong

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I understant it. I am using NY Zip for creating cookies. But I am confused about how to generate. Idid search in htis forum to get a guide line but did not understand properly like what is he section 1 nad section 2 code in .ini file. I will beter if u can modifi my .ini file for generating channel.xml file

Attachments: 
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I did try by following guide u refer. But no luck. new error created. Please check log file and suggest me a solution

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Thanks for your reply.   I did not understant the this sentance

 

use the url_index for mono >5.0.0.1

 

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Now I am get this in my channel.xml file

 

<?xml version="1.0" encoding="UTF-8"?>
<site generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.1 -- Jan van Straaten" site="directv.com">
  <channels>
    <channel update="i" site="directv.com" site_id="#_" xmltv_id=" ()"> ()</channel>
    <channel update="i" site="directv.com" site_id="#" xmltv_id="">
    </channel>
  </channels>
</site>

Attachments: 
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

still no luck waiting for  your kind reply to fix my issue. It will be great if you generage directv ch list for NY ( zip 11221)

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I did try what you told me to do. I did use mono version >= 5.0.1.1   but still I did not able to generate Direct tv channel xml list. My bad.  I did try all the possible way. Still no success following is the generated channel.xml file tw2 file generated

 

1. direct-channel.xml

root@vps155939:~/EPG# cat directv-channel.xml
<?xml version="1.0" encoding="UTF-8"?>
<tv generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.1 -- Jan van Straaten" generator-info-url="http://www.webgrabplus.com">
  <channel id="abc">
    <display-name lang="en">ABC</display-name>
    <url>http://www.directv.com</url>
  </channel>

 

 

 

2.  directv.com.channels.xml

root@vps155939:~/EPG# cat directv.com.channels.xml

<?xml version="1.0" encoding="UTF-8"?>
<site generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.1 -- Jan van Straaten" site="directv.com">
  <channels>
    <channel update="i" site="directv.com" site_id="#_" xmltv_id=" ()"> ()</channel>
    <channel update="i" site="directv.com" site_id="#" xmltv_id="">
    </channel>
  </channels>

 

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

Many thanks for your reply and help . Basically I want to learn and that's why trying from last night. But somehow I did not get your point. I am really thankful about your all effort and time u gave to resolve my issue. It will be greate and I can trace my mistake if you could sare the .ini file that u used to generate this channel.xml    Hope you would not mind. And again I am really sorry for my ineligibility regarding this issue.

bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

not both one is enable. 1st one is enable any 2nd one is disable uins * mark.

I did enable mono version >= 5.0.1.1  in my .ini file and try several time.  But get same result

I do have some confusion regarding when I enable channel section then should I disable any part of the .ini file? 

 

Now I am using ur cokies and channel xml but still no show in iNdex page error. I think Some think not still correct in my ini file

 

 

Attachments: 
bonz777
Offline
bonz777's picture
Donator
Joined: 5 years
Last seen: 3 weeks

I did use another .ini file and data now grabbing.... Many thanks for your all support

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl