You are here

Add one hour to all program grabbed

8 posts / 0 new
Last post
Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years
Add one hour to all program grabbed

In am grabbing some channels from the rytec source. All programs I am grabbing have the wrong timing, are all one hour early. Is there one way to fix it? I tried to chage the string

site {url=merge-xmltv-utc|timezone=Europe/Rome|maxdays=7|cultureinfo=it-IT|charset=UTF-8|titlematchfactor=90|keepindexpage}

from the file merge-xmltv-utc.ini made from the amzing Blackbear199 but nothing happen.

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years
Blackbear199 wrote:

you dont want to mess with the timezone.

 i would use xmltv_time_correct to add the 1 hr,then merge it with merge-xmltv-utc.ini as you normally do.

could do it in merge-xmltv-utc.ini but you would need a custom ini just to scrub the rytec xml's.just adds more clutter for something so simple.

it also has potential to cause trouble because of the way the times are converted to UTC.

The solution you suggest me look like cool. But reading the istructions I need setup all channels in chans2correct.xml. Is there one way to correct alla channels without make a long configuration?

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years

The real problem is Rytec many times change the name of the channels, can the tool make one log about? Someting like channel "canale 5" not found?

Can you make me one example? Maybe I don't understand :(

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years

Yes is one gzip, but I know the way to write a short script to dowload and unzip :) I am thinking also to grab the channels automatically from the config file and make the confiuration automatically.

 

http://www.vuplus-community.net/rytec/rytecxmltvItaly.gz

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years

The tool always give me the error System.IndexOutOfRangeException after scanned some channes :(

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years

No, if there are not all channels like webgrab doesn't start. I understood the problem, in rytec there is one channel double.

</channel>
<channel id="RSILa1.ch">
<display-name lang="it">RSI La1 HD</display-name>
</channel>
<channel id="RSILa2.ch">
<display-name lang="it">RSI La1 HD</display-name>
</channel>

Blackbear199 wrote:

if i remeber right if you have a channels in the chans2correct.xml and it can't find in your guide.xml it will give a error,forget which error.

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years

Mmmm... But anyway the tool doesn't look like a really good solution, if there are double channels inside the source, close itself and everytime find one different error, ask me to push one button or it wait forever. In my mind I want lunch it automatically with one script and don't care, can be fine if automatically skip the errors.

Maybe the other solution you told about .ini can be better, do you have any suggestion about? Maybe in some old post someone did something similar but I cant find it.

PS. I don't really understand, why if I change the gmt the timing don't shift one hour?

Tapiocapioca
Offline
Has donated long time ago
Joined: 6 years
Last seen: 3 years

The solution is more easy than I tought!

sed -i 's/+0200/+0100/g' rytecxmltvSkyIT.xml

With this command on the rytec file is fixed the timing :D

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl