You are here

26/09/2023 - V5.1.3 (beta) ( Dot Net 8. 0 & Linux Ubuntu Install)

12 posts / 0 new
Last post
wahaib1981
Offline
Donator
Joined: 1 year
Last seen: 1 week
26/09/2023 - V5.1.3 (beta) ( Dot Net 8. 0 & Linux Ubuntu Install)

Hello Admins,
Just wanted to confirm if the current recent Beta Version is compatible with .NET 8.0 (Latest Version of .NET.
https://dotnet.microsoft.com/en-us/download/dotnet/8.0

OR
Otherwise we should stick with older .NET version ( .NET 7.0 )

Your advise will be highly appreciated.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

beta=eval Then the big change was from 3.x (mono) to 5.x (dotnet)the 5.x has new features that also work with rex, mdb. We usually test them as much as we can, before they are public, so even beta or eval should not create problems.

wahaib1981
Offline
Donator
Joined: 1 year
Last seen: 1 week

Hello Admin,
Does 5.1 also Require Mono Version ?
if any idea or instruction related to that for V 5.1 will be highly appreciated.

And also will I be required to inform you guys about ny up gradation in my License to use with V5.1 ?
Currently I use V3.3
My License is (Customs License) With Unlimited Hardware IDs

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

5.1 (build 2) needs dotnet 7
will not change your license

wahaib1981
Offline
Donator
Joined: 1 year
Last seen: 1 week

Hello Mat,
Please Advise the latest Build 5.1.1 ( Beta ) is recommended and tested to be use
or we should Remain at 5.1 (Build 2)
---
I know you have do as much as possible, but as 5.1.X is major Release, a proper detailed documentation on the forum is highly appreciated about these builds.

FStimm
Offline
Donator
Joined: 5 years
Last seen: 2 months

Hi,

can I check with you, whether .NET 8 is also supported? Unfortunately Synology only has packages for .NET 6 and .NET 8. After having tried, it appears that compatibility check is for .NET = 7. I assume that .NET 8 is downward compatible and could likely work, but the version check for .NET 7 throws me an error when only .NET 8 is installed. Can I configure Webgrab, so that it checks for "7 or higher, like .NET >= 7"?

Thanks
Frank

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

not exactly how it works.
V5.x is compliled with net 7 so thats whats needed.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

Earlier version started with dotnet 6, then 7. I had 6 and then update to 7 and works fine, may be if you contact Jan he can give you a more precise answer.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

You lucky ;) latest version:
Version 5.1.4.5 evaluation
upgrade : to .NET 8.0
improved : datetime pattern parsing , now uses either the site CultureInfo or the invariant
fix : one more bug in if / else / loop

FStimm
Offline
Donator
Joined: 5 years
Last seen: 2 months

Excellent! Thanks for your swift reply, Mat! I give it a try then.

FStimm
Offline
Donator
Joined: 5 years
Last seen: 2 months

I assume that a version that was compiled with .NET 7 will also run with .NET 8. But I am not a developer and that certainly requires additional testing. Most likely this error is caused because you check for .NET version to be exactly 7. .NET has a high degree of backward compatibility.

See here for instance: https://world.optimizely.com/blogs/Magnus-Rahl/Dates/2022/10/five-six-se...

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 8 hours

the net version webgrab has been compiled with needs to be installed.
webgrab V5.1.4.5 compiled with net 8 wont work with net 7 and V5.1.4.4 compiled with net 7 wont work with net 8.

its the same as it was for V3.x/V2.x/V1.x. it used netframework(end of life and replaced with dotnet).
when it was compiled with a newer netframework users had to also update their installed netframework version.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl